Elite Dangerous ONLY Supported on Oculus Rift 1.3

The Oculus Rift 1.3 runtime is the only version that provides support for Elite Dangerous on the Rift consumer version and DK2.

You will need this runtime as well as the latest version of Elite: Dangerous or Elite Dangerous: Horizons to play using your Oculus Rift. Oculus no longer supports previous Oculus runtimes (0.5 and 0.8) and as such they have retired support for development kits which only work with these versions.

I have purchased Elite Dangerous - How do I enable in Oculus Home?

You'll need to grab a key and redeem in the Oculus store.

  1. Log into your Frontier Account
  2. Click on Partner Keys
    Copy the code
  4. Then back into Oculus Home on your desktop
  5. Go to Settings - Account - Redeem Code and paste your code
Note. If you already have Elite installed. Oculus home does not see that copy and will try to reinstall again. The easiest thing to do is to remove any current installation and reinstall again.

Elite Dangerous ONLY Supported on Oculus Rift 1.3" data-width="50" data-layout="button_count" data-action="like" data-show-faces="true" data-share="true">

blog comments powered by Disqus