Oculus 1.3 does work with the DK2

If you're still waiting for your consumer version of the Rift to arrive, and you still have your DK2. You'll be pleased to hear the consumer release of the Oculus software does work with the DK2. So far, I tried the movie player, Lucky's Tale, ADR1FT, Henry, Lost, Oculus Dreamdeck and Elite Dangerous on the DK2.

All worked without a problem. However, it will display a message stating the DK2 is not supported as you can see above, but it does work and work very well.

Download Oculus Software

If you're using the DK2 and it asks you to test remote (which you won't have) then just skip that section of the setup.

Oculus 1.3 does work with the DK2" data-width="50" data-layout="button_count" data-action="like" data-show-faces="true" data-share="true">

blog comments powered by Disqus